Author Topic: New to forum and have a 1910 problem  (Read 1716 times)

0 Members and 1 Guest are viewing this topic.

snwrdr33

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
New to forum and have a 1910 problem
« on: June 03, 2016, 08:47:44 PM »
Hi all, I have a 1910? 32acp #33141 and for some reason I can not get it back together. I have watched the Youtube videos very simple to breakdown and reassemble but, when I try to slide it back to drop n the barrel it gets hung up and then I have to put the clip back in to free slide. I have tried it without the firing pin and it seems to go back ok but then have a hard time sliding it forward.. :-\  I have taken it to a local gunsmith but he to can't seem to get it back together. Anybody have any thoughts? It did fire before I took it apart. Thanks for any help you may give...

1914mauser

  • Hero Member
  • *****
  • Posts: 580
  • Karma: +24/-0
    • View Profile
Re: New to forum and have a 1910 problem
« Reply #1 on: June 04, 2016, 12:49:48 PM »
Okay, if it is .32 caliber it is a 1914. 1910s are .25 caliber. It sounds like you may have the magazine catch spring on the wrong side of the slide hold open device, top end. Where are you located? It is easier to show than explain.

Regards,
B. Mason
NAPCA member, NRA life member
aim small, mis small

snwrdr33

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: New to forum and have a 1910 problem
« Reply #2 on: June 04, 2016, 01:00:52 PM »
I'm in Alaska probably to far from you or any one who can help :(

1914mauser

  • Hero Member
  • *****
  • Posts: 580
  • Karma: +24/-0
    • View Profile
Re: New to forum and have a 1910 problem
« Reply #3 on: June 04, 2016, 04:16:31 PM »
I can try to talk you through this but lets start with some questions. When you disassembled it did you remove the magazine catch spring?
B. Mason
NAPCA member, NRA life member
aim small, mis small

snwrdr33

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: New to forum and have a 1910 problem
« Reply #4 on: June 04, 2016, 04:48:26 PM »
No I did not in fact I did just the simple break down. If this is considered the simple breakdown? Slid back the slide pulled out the pin removed the barrel inserted the clip back in to slide out the slide. 1914Mauser I did get the pistol back together this morning after re googling the 1914 (Thank you) I have put up a new post under the 1914 forum asking some new questions.